App update conflict - Google Play Store
Back to All

App update conflict - Google Play Store

Greetings,

Having an app version already deployed on Google Play Store and pushing and updated version generated by GoNative and trying to update an already installed app on a device, we get the "App not installed as it conflicts with an existing package".

The app version was changed from 2.2.3 to 2.2.4 before rebuilding it.

Last time we've pushed an update like that it broke already existing OneUser accounts and the existing users had to migrate to get them assigned the new OneUser ID.

How can these issues be addressed?

We are kind of forced to push an update on Google Play as our version gets a notification that a GoNative update is required (I guess that's because of the latest Google versioning issues)

Best regards,

Eduard.